XFree86 4.5 のインストール

メモ:

XFree86 4.5Plamo Linuxに新規でバイナリからインストールします。

自分の環境に必要なバイナリを次のサイトからダウンロードします。(ftpサイト)

最初にXinstall.sh をダウンロードし自分の環境に合うバイナリの情報を取得します。Xinstall.sh を任意のディレクトリにダウンロード後、以下のように実行します。

# sh Xinstall.sh -check

Checking which OS you're running...
uname reports 'Linux' version '2.4.31-plamo', architecture 'i586'.
libc version is '6.3.3' (6.3).

Binary distribution name is 'Linux-ix86-glibc23'

If you don't find a binary distribution with this name, then
binaries for your platform are not available from XFree86.org.

Binary distribution name is ‘Linux-ix86-glibc23’のように必要なバイナリを知ることができます。

上記、ディレクトリから必要なファイルを任意のディレクトリにダウンロードします。

XFree86をインストールするのに必要なファイルは、次のファイルになります。

  • extract tarball 展開用のユーティリティ
  • Xbin.tgz X クライアント/ユーティリティと実行時ライブラリ
  • Xlib.tgz 実行時に必要なデータファイル
  • Xman.tgz マニュアルページ
  • Xdoc.tgz XFree86 に関する文書
  • Xfnts.tgz フォントの基本セット
  • Xfenc.tgz エンコーディングデータの基本セット
  • Xetc.tgz 実行時設定ファイル
  • Xvar.tgz 実行時データ
  • Xxserv.tgz XFree86 の X サーバ
  • Xmod.tgz XFree86 の X サーバ用のモジュール
  • Xrc.tgz

足らないといわれたファイル

  • Xrc.tgz

後で追加したファイル。

  • Xprog.tgz

ダウンロードが終了したらインストールです。

# sh Xinstall.sh

もし、ファイルが足らない場合は、インストーラーが足りないファイルを教えてくれます。

                Welcome to the XFree86(R) 4.5.0 installer

You are strongly advised to backup your existing XFree86 installation
........
Do you wish to continue? (y/n) [n]

You appear to have an existing installation of X.  Continuing will
overwrite it.  You will, however, have the option of being prompted
before most configuration files are overwritten.

Do you wish to continue? (y/n) [y]

Do you want to move them to /etc/X11 and create the necessary
links? (y/n) [y]

Moving /usr/X11R6/lib/X11/app-defaults to /etc/X11/app-defaults ...
./
GV
Do you wish to continue? (y/n) [y]

Configuration files will now be installed.  There are some cases where
installing these files over existing files will adversely affect your
previous desktop configuration, and some other cases where the new files
are essential for the correct operation of the new installation.
These cases will noted before any old files are overwritten.

Do you want to overwrite the app-defaults config files? (y/n) [n]

Note: the new xterm entries are required to take full advantage
of new features, but they may cause problems when used with
older versions of xterm.  A terminal type 'xterm-r6' is included
for compatibility with the standard X11R6 version of xterm.

Do you wish to continue? (y/n) [y]

NOTE: installing these links will overwrite existing files or
links.

Do you wish to have the (new) links installed (y/n)? [n]

If you are going to use rstart and /usr/X11R6/bin isn't in the
default path for commands run remotely via rsh, you will need
a link to rstartd installed in /usr/bin.

Do you wish to have this link installed (y/n)? [n]

Installation complete.

The log for this installation is XFree86-install.log.25234

Installation complete.と表示されインストールが終了します。

インストールが終了したら、/usr/X11R6/bin のパスが通っているかとld.so が /usr/X11R6/lib を指せるようになっているかを確認します。

もし、設定されていない場合、Plamo Linux ではlogin.defsやprofile,.bashrc,.cshrcなどにパスを指定します。

ld.soは、/etc/ld.so.confに/usr/X11R6/libを追加し/sbin/ldconfigを実行します。